Home > Pear Install > Pear Install Pecl/json Cannot Find Config.m4

Pear Install Pecl/json Cannot Find Config.m4

The error message says that APD cannot compile on your version of PHP. Are you new to LinuxQuestions.org? Starting to download xhprof-0.9.1.tgz (925,239 bytes) .................done: 925,239 bytes 11 source files, building running: phpize Cannot find config.m4. cd / find -name 'config.m4' Yet, "yum install m4" gives me "Package m4-1.4.13-5.el6.i686 already installed and latest version Nothing to do" Echo $PATH gives me Code: /usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin phpize is actually in

I guess it's because of the php but cannot be sure. You may have to register before you can post: click the register link above to proceed. Ensure you have the necessary dependecies (php, php-pear, php-devel, gcc, make): * $ sudo yum install gcc make * $ sudo yum install php php-pear php-devel Is there any particular reason you want to use the latest php? 1 members found this post helpful. http://stackoverflow.com/questions/24612979/cannot-find-config-m4-while-running-phpize-in-the-installation-of-apd-using-p

share|improve this answer answered Apr 11 at 11:58 kenorb 23k9157133 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign up Results 1 to 8 of 8 Thread: JSON installl problem Thread Tools Show Printable Version Email this Page… Display Linear Mode Switch to Hybrid Mode Switch to Threaded Mode 08-08-2011,02:08 PM How should I remove the default Home item? current community chat Stack Overflow Meta Stack Overflow your communities Sign up or log in to customize your list.

Any ideas how to resolve this:# pear install json-1.2.1.tgz 11 source files, buildingrunning: phpizeCannot find config.m4.Make sure that you run '/usr/bin/phpize' in the top level source directory of the moduleERROR: `phpize' Anytime! :) January 17, 2012 at 2:35 PM Bob said... I'm a Muslim Egyptian girl. Password Linux - Server This forum is for the discussion of Linux Software used in a server related context.

If you really need to build it, you'll need php development libraries, probably php-dev on ubuntu. I also observed that I am getting Code: [[email protected] modules]# service httpd restart Stopping httpd: [ OK ] Starting httpd: [Wed Aug 22 07:42:21 2012] [warn] module php5_module is already loaded, extension=apc.so ;extension=oauth.so ;extension=json.so I have done this but the error still remains.. http://forum.directadmin.com/showthread.php?t=41205 LinuxQuestions.org > Forums > Linux Forums > Linux - Server Error running phpize: Cannot find config.m4 User Name Remember Me?

in PEAR/Downloader/Package.php on line 1528 Warning: is_file(): Unable to find the wrapper "channel" - did you forget to enable it when you configured PHP? What do I do? why is rdsk not available on linux? Works in Debian Lenny, might work elsewhere: ----%<---- pear update-channels pecl install --force xhprof cd /tmp/pear/download/ cp -a xhprof-0.9.2/extension/* xhprof-0.9.2/ sed -i -r -e "s%()%\1\2%" package.xml tar czf xhprof-0.9.2.tgz package.xml xhprof-0.9.2

asked 2 years ago viewed 11329 times active 7 months ago Upcoming Events 2016 Community Moderator Election ends Nov 22 Get the weekly newsletter! OK.. Absolute values of complex irreducible characters of finite groups Do the Leaves of Lórien brooches have any special significance or attributes? It may be down for maintenance or configured incorrectly.

By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. share|improve this answer edited Feb 18 '15 at 17:21 Lankymart 7,44342254 answered Jul 11 '14 at 5:05 balintpekker 1,07611131 2 Thanks for this write up! redhat19 View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by redhat19 08-22-2012, 07:12 AM #14 bathory LQ Guru Registered: Jun 2004 Location: By .::Gsmdenis::.

Success! Are there still systems around with a /bin/sh binary? Download sources 2. Please visit this page to clear all LQ-related cookies.

Linked 1 Issues installing interbase/firebird PHP extension on MAMP 0 Unit testing PHP code that does fgets() Related 52sudo pecl install apc returns error10Install YAML Pecl PHP Extension on MAMP48Install PECL Remove Page Titles from Panels - Drupal Theme There may be times when you want to remove a page title from a page, but leave it as the meta title. Looks like it expects to find config.m4 in the top-level directory (?).

yum search php | grep json 2#.

This time I tried it with verbose options turned on, in case there is a clue in the logs: sudo /usr/bin/pecl -vvvvv install apd Warning: file_exists(): Unable to find the wrapper Please click the link in the confirmation email to activate your subscription. What legal documents are Italian citizens supposed to carry when traveling to Ireland? Regards bathory View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by bathory 08-21-2012, 12:16 PM #9 redhat19 Member Registered: Jan 2012

I've reached a whole new level of problems where it fails the sanity checks on ./configure. –Incognito Dec 1 '11 at 17:34 Why not paste the results from an To see if it's php the culprit, comment out the line: Quote: LoadModule php5_module ... Try our newsletter Sign up for our newsletter and get our top new questions delivered to your inbox (see an example). This summary applies for PHP 5.6.2 APD 1.0.1 and might be incorrect for other versions.

I unpacked pecl.php.net/get/apd-1.0.1.tgz, ran phpize on it (which works), and ran configure. Thanks. First upgrade pear via "pear upgrade pear" and then "pecl install channel://pecl.php.net/xhprof-0.9.2". [2012-01-24 17:37 UTC] [email protected] -Status: Assigned +Status: Closed Copyright © 2001-2016 The PHP Group All rights reserved. Why is the 'You talking to me' speech from the movie 'Taxi Driver' so famous?

I am still getting Code: Server error The website encountered an error while retrieving http://mywebsite.com/. Visit the following links: Site Howto | Site FAQ | Sitemap | Register Now If you have any problems with the registration process or your account login, please contact us. UX team under Product management or Engineering or an Independent? Make sure that you run '/usr/local/php5/bin/phpize' in the top level source directory of the module Open Source may be free but it sure ain't cheap! 90% of being smart is knowing

apt-get install php5-dev was executed successfully and phpize exists in /usr/bin.